Project

General

Profile

Support #1064

Compatibility issue with Redmine plugin "Wiki extensions"

Added by André Bachmann almost 7 years ago. Updated almost 7 years ago.

Status:
担当(Assigned)
Priority:
通常(Normal)
Assignee:
Target version:
-
Start date:
06/26/2012
Due date:
% Done:

0%

Estimated time:

Description

I tried to use the plugin "Wiki extensions" 0.3.9 with my Redmine 1.3.1. According to this page, this should be compatible.
However, it is not. If I start my Redmine with plugin version 0.3.9, it won't start. I get this in my mongrel.3001.log:

...
** Mounting Rails at /redmine...
/opt/redmine-1.3.1-0/apps/redmine/lib/redmine/plugin.rb:131:in `requires_redmine': redmine_wiki_extensions plugin requires Redmine 2.0.0 or higher but current is 1.3.1.stable (Redmine::PluginRequirementError)
    from /opt/redmine-1.3.1-0/apps/redmine/lib/redmine/plugin.rb:124:in `each'
    from /opt/redmine-1.3.1-0/apps/redmine/lib/redmine/plugin.rb:124:in `requires_redmine'
    from /opt/redmine-1.3.1-0/apps/redmine/vendor/plugins/redmine_wiki_extensions/init.rb:69:in `evaluate_init_rb'
    from /opt/redmine-1.3.1-0/apps/redmine/lib/redmine/plugin.rb:67:in `instance_eval'
    from /opt/redmine-1.3.1-0/apps/redmine/lib/redmine/plugin.rb:67:in `register'
    from /opt/redmine-1.3.1-0/apps/redmine/vendor/plugins/redmine_wiki_extensions/init.rb:62:in `evaluate_init_rb'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:158:in `evaluate_init_rb'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:154:in `evaluate_init_rb'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:48:in `load'
    from /opt/redmine-1.3.1-0/apps/redmine/config/../vendor/plugins/engines/lib/engines/plugin.rb:44:in `load'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:38:in `load_plugins'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:37:in `each'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:37:in `load_plugins'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:369:in `load_plugins'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:165:in `process'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `send'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `run'
    from /opt/redmine-1.3.1-0/apps/redmine/config/environment.rb:24
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:147:in `rails'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:113:in `cloaker_'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:149:in `call'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:149:in `listener'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:99:in `cloaker_'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:50:in `call'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:50:in `initialize'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:84:in `new'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:84:in `run'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/command.rb:212:in `run'
    from /opt/redmine-1.3.1-0/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:281
    from /opt/redmine-1.3.1-0/ruby/bin/mongrel_rails:19:in `load'
    from /opt/redmine-1.3.1-0/ruby/bin/mongrel_rails:19
...

Wiki extensions 0.3.8 is the last version which works fine with my Redmine 1.3.1.

History

#1

Updated by Haru Iida almost 7 years ago

  • Project changed from r-labs to Wiki Extensions
  • Status changed from 新規(New) to 担当(Assigned)
  • Assignee set to Haru Iida

Also available in: Atom PDF