プロジェクト

全般

プロフィール

Support #1378

Redmine-3.0.xの使用について

Hiroyuki Teradaほぼ3年前に追加. ほぼ3年前に更新.

ステータス:
新規(New)
優先度:
通常(Normal)
担当者:
-
対象バージョン:
開始日:
2015/05/04
期日:
進捗率:

0%

予定工数:

説明

寺田と申します。

現在CentOS7, Redmine3.0.2にて使用させていただこうとしているのですが、
下記のようにしてインストールしましたところ、マイグレーション時にエラーが発生してインストールできませんでした。

cd /var/www/redmine-3.0.2/plugins/
git clone https://github.com/planio-gmbh/redmine_issue_extensions.git
bundle exec rake redmine:plugins:migrate RAILS_ENV=production

エラーは下記のとおりです。

An error occurred while loading the routes definition of redmine_issue_extensions plugin (/var/www/redmine-3.0.2/plugins/redmine_issue_extensions/config/routes.rb): You should not use the `match` method in your router without specifying an HTTP method.
If you want to expose your action to both GET and POST, add `via: [:get, :post]` option.
If you want to expose your action to GET, use `get` in the router:
  Instead of: match "controller#action" 
  Do: get "controller#action".

Rubyのバージョンは2.1.5p273を使っております。

対策方法や他に確認すべき事項などありましたらご教示いただければと思います。

よろしくお願いいたします。

履歴

#1 Takashi Takebayashiほぼ3年前に更新

Hiroyuki Terada は書きました:

対策方法や他に確認すべき事項などありましたらご教示いただければと思います。

寺田さん、こんにちは。
http://www.r-labs.org/projects/r-labs/wiki/Issue_Extensions に記載の通り

注意
本プラグインは、Redmine 1.4.x (version 0.1.0)、Redmine 2.0.x (version 0.2.0) でのみ動作します。

こちらのプラグインはRedmine3.0.x系に対応していません。

#2 Takashi Takebayashiほぼ3年前に更新

  • 対象バージョンSome distant future にセット

#3 Hiroyuki Teradaほぼ3年前に更新

ご返答いただきありがとうございました。

Redmine-2.6.4でのお問い合せと合わせてバージョン違いでの質問となりご迷惑おかけして申し訳ございません。こちらも将来的に対応されるご予定などありましたら教えていただければ幸いです。

他の形式にエクスポート: Atom PDF