Defect #1492

iframe working on some websites and not on others

Added by Ezequiel Nicolazzi about 3 years ago. Updated about 3 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:


What steps will reproduce the problem?

First of all, thanks for the wonderful plugin! Great tool!
When trying to use the iframe macro, it works for me on some websites but not on others. And I cannot find the reason why.

Steps to reporduce the issue:
Creating a wiki page on redmine and adding:

Will give me a blank page.. the iframe fails to create. I've tried using http, tried without http/s, tried without www. Nothing worked.
However, when using my company's website address () it works perfectly.

Tested on Chrome, Mozilla and Safari browsers. Redmine 3.3.1.stable (see below).

What is the expected output? What do you see instead?

An iframe for all websites. I see a blank page (e.g. no output). The space is dedicated but no output is shown.

Please give us a result of following command.

% ruby script/about

Redmine version 3.3.1.stable
Ruby version 2.3.0-p0 (2015-12-25) [x86_64-linux]
Rails version
Environment production
Database adapter Mysql2
Subversion 1.7.14
Redmine plugins:
redmine_email_fetcher 0.3.1
redmine_user_default_group 0.0.1
redmine_wiki_extensions 0.7.0

Please provide any additional information below.


Updated by Haru Iida about 3 years ago

  • Assignee set to Haru Iida

Some website adds "X-Frame-Options" in HTTP response header. It affects how browsers treat frames.
Google sets X-Frame-Options to "Deny" and browsers does not display it in iFrame.


Updated by Haru Iida about 3 years ago

  • Project changed from r-labs to Wiki Extensions

Updated by Ezequiel Nicolazzi about 3 years ago

thanks a lot for your quick response.

My actual target website was - of course - not google. I used that as a (stupid) example. I'm trying to display this website
I looked at the source code and I could not find any X-Frame-Option active in the website.

If I write a simple html with an iframe tag, the google website does not display (as expected following your explanation above) but my website does.
My question is: is there any other possible explanation why a website would not display on the "iframe" macro.

This is the result when I attempt the following command:



Updated by Haru Iida about 3 years ago

I think your redmine run with https. You can't mix http page into https page because of security.

Also available in: Atom PDF